56th day…

56th day of the 1000 day challenge.  This morning I didn’t work out 😦

However, I made up for it tonight a little.  I did the Power 90 Level III-IV Circuit/Sculpt tape tonight just a few minutes ago, and I used 20 pound weights on half of the exercises!  

This is the first time I’ve tried to use 20 lb weights. Up til now I was only using 10 lb weights as max on this workout.  I probably will feel this in the morning, but maybe not.  When I switched to the 10 lb weights on some of the more tough exercises it was like lifting paper, lol.  I will probably stick with this strategy going forward.

I also upped the weights on the kettlebell to 30 lbs tonight.  I have not tried any swinging with it but probably will in the near future.

The reason I was able to up the weights tonight is that a few days backmom and dad found some more of the old weights in the garage or basement from many years ago… so I had them in my trunk the last few days til today…  It’s still not the best set in the world… Had to use some duct tape on a few of them where age was starting to break down the plastic around the edges, but it’s all good.  I wish I had 4 of the ten lb weights to do the curls and stuff, but I made do with a couple of 5 lbs on one side and a 10 lb on the other to balance it out.  It looks a little odd, but it works.  I do have a couple of 8.5 lb weights I could use for curls, but no matching set for them so I could have one in each arm… would be sort of weird and unbalanced doing 17 lbs in one arm and 20 in the other… so I’ll stick with the two 10 lbs on one arm and a 10 lb + 2 of the 5lbs on the other arm.

Advertisements